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1. Item CSV creation procedures

1. Open Merge Worksheet Template for CSV ReDiscovery Import -

SASGER _GRANT\Converted WAV\FS Inventory Misc\Import templates\Merge Worksheet
Template for CSV ReDiscovery Import.xlsx

2. Select ‘Save As’ add “_YYYYMM"” to the end of the file name and save to the corresponding import
inventory year, e.g. S:\SGER_GRANT\Converted_WAV\FS_Inventory_Misc\Import inventories\2003
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3. Open the CSV Import Template - S\SGER GRANT\Converted WAV\FS Inventory Misc\Import
templates\REd _export_working 2017-09-05 B.xIsx

4. Select ‘Save As’ name file ‘ImportCSVYYYYMM” and save to the corresponding import inventory year,
S:\SGER_GRANT\Converted_WAV\FS_Inventory_Misc\Import inventories\2003

This document covers the population of the eight columns of unique metadata in the CSV Template for
import into Re:Discovery.

e Merge Worksheet Template is the excel worksheet populated with the appropriate equations for
simplified creation of metadata strings

e Import inventory refers to the inventory worksheet of the month and year from which information is
being collected — S\SGER_GRANT\Converted WAV\FS Inventory Misc\import inventories

® CSV Template refers to the excel CSV worksheet we are creating which is to be used for the import of

objects into Re:discovery

Title | Column E (refers to the column in the Re:discovery CSV import template)
Format: Channel/File Name - Date (yyyy-mm-dd) - Start Time

1. Copy Start Time (column B) from Import inventory

2. Paste into column B, row 2 of Merge worksheet
o0  While column is selected, CTRLH
m Find what: a single space (“ “)
m Replace with: with no space (“”)
e Find All > Replace All > Close
o0 Select data in column again
m Data > Text to Columns
m Fixed Width, 10
m  Next > select Text as Column data format > Finish

3. Column C should populate with start time

4. Copy/ Paste channel/file name (column f) from import inventory into column A of the Merge worksheet

5. Column D is the completed Title with equation: =A2&" "&TEXT(B2,"yyyy-mm-dd")&" "&C2

6. Copy column D > Paste into column E, values only, of CSV Template

File Unit Nbr | Column C (refers to the column in the Re:discovery CSV import template)
File Unit Nbr is the Channel / Filename

1. Copy from column A of Merge Worksheet and paste into column C of CSV import template

2. Additional instructions:
e Copy from column F (channel/file name) of Import inventory
e Paste into column A of the Merge worksheet
e Copy Column A > Paste into CSV Template
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Item Nbr | Column D
Format: original file name (column H)
Example: c101_15_01_2002_093337

1. Copy Original File Name (column H) from Import inventory
2. Paste into column W, row 2 of the Merge worksheet
3. Select column
4. Text to Column to separate .WAV portion of this
o Data > Text to Columns

m check Delimited only > check Other: “.“ > check Text > Finish

5. Copy Column W > Paste into column D of CSV Template

Series Nbr | Column B
Series Nbr is the day
Format: 20100105 (date without dashes)

1. Copy Date (column B) in Merge Worksheet

2. Paste into column E of Merge Worksheet
o Equation: =TEXT(B2,"yyyy-mm-dd")
3. Copy / paste equation of column F down

o Equation: =SUBSTITUTE(E2,"-","")

4. Column F populates with the Series Nbr in the appropriate date format (without dashes)

5. Copy Column F > Paste into column B, values only, of CSV Template

Dates | Column F
Format: currently shown as dd-mm-yyyy

1. Copy from Column E of the Merge worksheet
m  Yyyy-mm-dd
o To reformat the column of dates to “yyyy-mm-dd”, select all values (Shift + Ctrl +
Down Arrow) in column F
e Right click -> Format Cells -> Custom
e For Type, enter “yyyy-mm-dd”

2. Paste values only into column F of CSV Template

Notes / Prov: Provenance | Column G
Format: Migration Date, Date (yyyy-mm-dd)
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Note: Simple Merge of “Migration Date” and Migration Date (Column 1) of import inventory
1. Copy Migration Date (Column I) from Import inventory

2. Pasteinto column |, row 2 of Merge worksheet

3. Column J populates with equation: =H2&", "&TEXT(I2,"yyyy-mm-dd")

4. Copy ColumnJ > Paste values only into column G of the CSV Template

Summary Note | Column H

Format: Channel, Channel/File Name, Start Time, yyyy-mm-dd hh:mm:ss AM/PM End Time, yyyy-mm-dd
hh:mm:ss AM/PM Duration, yyyy-mm-dd hh:mm:ss AM/PM

Example: Channel 1, SCR 354[CR][CR]Start Time, 2002-01-15 09:33:39 AM[CR]End Time, 2002-01-1510:42:26

AM[CR]Duration, 1:08:47
o [CR] from Re:Discovery

1. Copy Channel (Column E) from Import inventory
2. Paste into column M of Merge worksheet

3. Copy channel/file name (Column F) from Import inventory
4. Paste into column N of Merge worksheet

5. Copy start time (Column B) from Import inventory
6. Paste into column P of Merge worksheet

7. Copy end time (Column D) from Import inventory
8. Paste into column R of Merge worksheet

9. Copy duration (Column C) from Import inventory
10. Paste into column T of Merge worksheet

11. Column S populates with equation: =L2&" "&M2&", "&N2&", "&02&": "&P2&",
"&Q2&": "&R2&", "&S2&": "&TEXT(T2,"[h]:mm:ss")

12. Copy Column U > Paste > Paste values only into column H of the CSV Template

Extent | Column |
Format: hh:mm:ss

1. Copy Column C from the Import inventory

2. Paste into Column | of the CSV Template (Extent)

Department of Personnel & Administration | Division of Central Services | Colorado State Archives | Policies and Procedures Page | 5



1.1 Complete Item CSV key

The completed Item level ingest CSV worksheet will contain the following columns, populated with the
following information, in the following order:

Column Name Format Example Information
Type
A Collection Nbr 8001 8001 Repeating
B Series Nbr HHHHHH 20050103 Unique
C File Unit Nbr Room name and/or number JBC Unique
D Item Nbr cRoom c1212 _03_01_2005_084450 | Unique
Number_dd_mm_yyyy_hhmmss
E Title Room Name_yyyy—mm—dd_hh: | JBC_2005-01- Unique
mm:ssAM/PM 03_08:44:50AM
F Dates yyyy-mm-dd 2005-01-03 Unique
Notes/Prov:Provenance | MigrationDate, YYYY-MM-DD MigrationDate, 2016-12-06 | Unique
H Summary Note ChannelChannel Channel 12, JBC, StartTime: | Unique
Number,StartTime: yyyy—mm-— 2005-01-03 08:44:50 AM,
dd hh: mm:ss AM/PM, EndTime: | EndTime: 2005-01-03
yyyy—mm-—dd hh: mm:ss 09:49:07 AM, Duration:
AM/PM, Duration: hh: mm:ss 1:04:17
I Extent Hh:mm:ss 1:01:17 Unique
J Creator Colorado General Assembly Colorado General Assembly | Repeating
K Creator Role Creator Creator Repeating
L Category Nonmusical sound recording Nonmusical sound Repeating
recording
M Genre/Form Nonmusical sound recording Nonmusical sound Repeating
recording
N Geogr Name Denver (Colo.)--lcsh Denver (Colo.)—Icsh Repeating
0] Form WAV file WAV file Repeating
P User 3 audio/x-wav, reformatted audio/x-wav, reformatted Repeating
digital digital
Q Notes/Prov:Notes This recording has been This recording has been Repeating
transferred into a WAV format transferred into a WAV
with PCM codec from the format with PCM codec
Freedom System. Original from the Freedom System.
format was WAV with G.723.1 Original format was WAV
codec. with G.723.1 codec.
R User 4 State of Colorado for public use. | State of Colorado for public | Repeating
Credit Colorado State Archives. | use. Credit Colorado State
Archives.
S Language English English Repeating
T Language:Language Eng Eng Repeating
Code
U Topic Term Legislative materials--lcsh Legislative materials--lcsh Repeating
Vv Web Ready? Y Y Repeating
W Location URI URI Unique
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1.2 Re:Discovery Item ingest procedures

1. Open the Re:Discovery application

2. Enter your username and password

3. Under the Navigator panel select the + icon for Colorado State Archives

4. Select Item

5. Select File -> Import/Export -> Import/Export Selected Fields

6. Select the Import records radio button

7. Select Next

8. Select ‘ASCII CSV’ from the File Type dropdown menu

9. Browse and select the Item CSV to import

10. Select Next

11. Confirm a sample of the CSV is displayed in the sample window, select Next

12. Select the ‘Open an existing template’ radio button, select Next

13. Select the ‘Show All Templates’ radio button

14. Select ‘'SGER AUDIO MODS/DC’ template, select Next

15. Select the ‘Update the target record (updates the matching record if found)’ radio button
16. Select Next

17. Click the ‘Start Import’ button

18. Select ‘Storage’ from the Reason dropdown menu in the Track Changes window
19. Select ‘OK’

20. Select ‘Yes’ from the confirmation popup window

21. Once ingest is complete move the imported CSV to the following directory — (year will vary)
SASGER_GRANT\Converted WAV\AFS_Inventory Misc\Import inventories\YYYY\processed

2. Series ingest

1. Open the item import located in the processed directory -
"S:\SGER_GRANT\Converted_WAV\FS_Inventory_Misc\Import
inventories\2002\processed\ImportCSVYYYYMM.csv"

2. Select ‘Save as’, add ‘_series’ to the end of the filename. Save the CSV to
S:\SGER_GRANT\Converted_WAV\FS_Inventory_Misc\Import inventories\YYYY.

This CSV will be used to import the series information for the SGER files to Rediscovery. Adding this
information will add contextual structure to the SGER collection within the RD databases.

*A column’s letter designation will change if/when columns are deleted.

File Unit Nbr | Column C (refers to the column in the Re:discovery CSV item import template)

Format: Channel Name - JBC
Item Nbr | Column D

Format: FSM filename - c1212_02_12 2002_090709

e Remove columns

Department of Personnel & Administration | Division of Central Services | Colorado State Archives | Policies and Procedures Page | 7



Title | Column C*

Format: Channel Name - Date (yyyy-mm-dd) - Start Time

Update title of column from “Title” to “Series Title”

Copy and paste contents of column B (Series) to column A of the second sheet of the CSV
Add the following text to column B — “Colorado General Assembly recordings,” and fill down
Enter formula into column C: =CONCATENATE(B1," ",Al1)

Fill down formula for column C

Copy and paste, values only, into Column C | Series Title of first sheet of CSV

ok wnE

Dates| Column D
Format: Dates — MM/DD/YYYY

Notes/Prov:Provenance | Column E
Format: MigrationDate, YYYY-MM-DD
Summary Note | Column F

Format: Channel #, Channel name, StartTime: YYYY-MM-DD HH:MM:SS AM/PM, EndTime: YYYY-MM-DD
HH:MM:SS AM/PM, Duration: HH:MM:SS

Extent | Column G
Format: HH:MM:SS

7. Select columns and delete

Category | Column F*

Text: Nonmusical sound recording
Form | Column |

Text: WAV file

User 3 | Column )

Text: audio/x-wav, reformatted digital
Notes/Prov:Notes | Column K

Text: This recording has been transferred into a WAV format with PCM codec from the Freedom System.
Original format was WAV with G.723.1 codec.

Location | Column Q
Text: uri

8. Select columns and delete
Notes | Column M

Format: Audio recordings of the Colorado General Assembly from [Month YYYY].

e Add to import CSV
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Inclusive Dates | Column N

Format: YYYY-MM

Add to import CSV

2.1 Complete Series CSV key

Column Name Format Example Information Type
A Collection Nbr 8001 8001 Repeating
B Series Nbr HittHHHH 20040105 Unique
C Series Title Colorado General | Colorado General Unique
Assembly Assembly
recordings, recordings,
[YYYYMMDD] 20040105
D Creator Colorado General | Colorado General | Repeating
Assembly Assembly
E Creator Role Creator Creator Repeating
F Genre/Form Sound Sound Repeating
G Geogr Name Denver (Colo.)-- Denver (Colo.)— Repeating
Icsh Icsh
H User 4 State of Colorado | State of Colorado Repeating
for public use. for public use.
Credit Colorado Credit Colorado
State Archives. State Archives.
I Language English English Repeating
J Language:Language | Eng Eng Repeating
Code
K Topic Term Legislative Legislative Repeating
materials--lcsh materials—Icsh
L Web Ready? Y Y Repeating
M Notes Audio recordings Audio recordings Unique
of the Colorado of the Colorado
General Assembly | General Assembly
from [Month from January
YYYY]. 2004.
N Inclusive Dates YYYY-MM 2004-01 Unique

2.2 Re:Discovery Series ingest procedures
1. Open the Re:Discovery application

2. Enter your username and password
3. Under the Navigator panel select the + icon for Colorado State Archives
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4. Select Series

5. Select File -> Import/Export -> Import/Export Selected Fields

6. Select the Import records radio button

7. Select Next

8. Select ‘ASCII CSV’ from the File Type dropdown menu

9. Browse and select the Series CSV to import, select Open

10. Select Next

11. Confirm a sample of the CSV is displayed in the sample window, select Next
12. Select the ‘Open an existing template’ radio button, select Next

13. Select the ‘Show All Templates’ radio button

14. Select ‘SGER _series’ template, select Next

15. Select the ‘Update the target record (updates the matching record if found)’ radio button
16. Select Next

17. Click the ‘Start Import’ button

18. Select ‘Yes’ from the confirmation popup window

19. Once ingest is complete move the imported CSV to the following directory — (year will vary)
SASGER_GRANT\Converted WAV\AFS_Inventory Misc\Import inventories\YYYY\processed

3. File Unit ingest

1. Open the item import located in the processed directory -
"S:\SGER_GRANT\Converted WAV\FS_Inventory_Misc\Import
inventories\2002\processed\ImportCSVYYYYMM.csv"

2. Select ‘Save as’, add ‘_fileunit’ to the end of the filename. Save the CSV to
S:\SGER_GRANT\Converted_WAV\FS_Inventory_Misc\Import inventories\YYYY.

This CSV will be used to import the file unit information for the SGER files to Rediscovery. Adding this
information will add contextual structure to the SGER collection within the RD databases.

*A column’s letter designation will change if/when columns are deleted.

Item Nbr | Column D
Format: FSM filename - c1212_02_12_2002_090709

e Remove column
Title | Column D*

Old Format: Channel Name - Date (yyyy-mm-dd) - Start Time

New Format: Channel Name, Date(yyyy-mm-dd)
e Enter formula into Column D: =C2&", "&TEXT(E2, "yyyy-mm-dd")
e  Fill down formula for Column D

Notes/Prov:Provenance | Column F
Format: MigrationDate, YYYY-MM-DD

Summary Note | Column G
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Format: Channel #, Channel name, StartTime: YYYY-MM-DD HH:MM:SS AM/PM, EndTime: YYYY-MM-DD

HH:MM:SS AM/PM, Duration: HH:MM:SS
Extent | Column H
Format: HH:MM:SS

Location | Column V
Text: uri

e Remove columns

3.1 Complete File Unit CSV Key

The completed Item File Unit level ingest CSV worksheet will contain the following columns, populated with

the following information, in the following order:

Column Name Format Example Information Type
A Collection Nbr 8001 8001 Repeating
B Series Nbr 20040105 20040105 Unique
C File Unit Nbr Room name JBC Unique
and/or number
D Title Room Name, JBC, 2004-01-05 Unique
YYYY-MM-DD
E Dates YYYY-MM-DD 2004-01-05 Unique
F Creator Colorado General | Colorado General Repeating
Assembly Assembly
G Creator Role Creator Creator Repeating
H Category Nonmusical sound | Nonmusical sound | Repeating
recording recording
I Genre/Form Sound Sound Repeating
J Geogr Name Denver (Colo.)-- Denver (Colo.)-- Repeating
Icsh Icsh
K Form WAV file WAV file Repeating
L User 3 audio/x-wav, audio/x-wav, Repeating
reformatted digital | reformatted digital
M Notes/Prov:Notes This recording has | This recording has | Repeating
been transferred been transferred
into a WAV format | into a WAV format
with PCM codec with PCM codec
from the Freedom | from the Freedom
System. Original System. Original
format was WAV format was WAV
with G.723.1 with G.723.1
codec. codec.
N User 4 State of Colorado | State of Colorado | Repeating
for public use. for public use.
Credit Colorado Credit Colorado
State Archives. State Archives.
0] Language English English Repeating
P Language:Language | Eng Eng Repeating

Department of Personnel & Administration | Division of Central Services | Colorado State Archives | Policies and Procedures

Page | 11



Code
Q Topic Term Legislative Legislative Repeating
materials--lcsh materials--lcsh
R Web Ready? Y Y Repeating

3.

© O ~NO UL WDN PP

S A R R A A AR R
O ~NO O~ WNPEO

19.

Department o

2 Re:Discovery File Unit ingest procedures

. Open the Re:Discovery application
. Enter your username and password
. Under the Navigator panel select the + icon for Colorado State Archives
. Select File Unit
. Select File -> Import/Export -> Import/Export Selected Fields
. Select the Import records radio button
. Select Next
. Select ‘ASCII CSV’ from the File Type dropdown menu
. Browse and select the Series CSV to import, select Open
. Select Next
. Confirm a sample of the CSV is displayed in the sample window, select Next

. Select the ‘Open an existing template’ radio button, select Next
. Select the ‘Show All Templates’ radio button
. Select ‘SGER fileunit’ template, select Next

. Select the ‘Update the target record (updates the matching record if found)’ radio button

. Select Next
. Click the ‘Start Import’ button
. Select ‘Yes’ from the confirmation popup window
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Once ingest is complete move the imported CSV to the following directory — (year will vary)
SA\SGER_GRANT\Converted WAV\AFS_Inventory Misc\Import inventories\YYYY\processed
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